Open main menu

Path of Exile Wiki β

The Embalmer

Lua error: callParserFunction: function "#ask" was not found.

The Embalmer is a unique Lua error: callParserFunction: function "#ask" was not found..

Modifiers

Applicable skill gems socketed in this item are supported by level 20 Lua error: callParserFunction: function "#ask" was not found.. All support stats are accounted for, including the mana multiplier.

Version history

Version Changes
3.0.0
  • Introduced to the game.